Back to overview
Downtime
Testing down
Nov 15, 2023 at 4:50pm UTC
Affected services
POS Integrations
Resolved
Nov 15, 2023 at 4:50pm UTC
All good again
Affected services
Created
Nov 15, 2023 at 4:50pm UTC
just a test
Affected services